Cloudflare Service Outage
Incident Report for JetRails
Resolved
This incident has been resolved
Posted Feb 18, 2021 - 21:56 CST
Identified
Cloudflare service is currently experiencing a regional outage. We are monitoring the incident and will provide updates as they become available.
Posted Feb 18, 2021 - 21:38 CST
This incident affected: JetRails Managed Network and JetRails Cloud Network.