Cloudflare Service Issues

Incident Report for JetRails

Resolved

Cloudflare has implemented a fix, all services are restored and we are monitoring further
Posted Jun 21, 2022 - 02:21 CDT

Identified

Cloudflare is investigating wide-spread outage affecting all of its services
Posted Jun 21, 2022 - 02:10 CDT
This incident affected: JetRails Managed Network and JetRails Cloud Network.