This incident has now been resolved, all functionality has been restored
Posted Nov 18, 2025 - 11:57 CST
Monitoring
Cloudflare team has implemented a fix and at this time all services have been recovered. We are monitoring our managed network to verify.
Posted Nov 18, 2025 - 08:49 CST
Identified
Cloudflare team has identified the issue and fix is being implemented. Most of the services have recovered at this time with minor error rates still remaining.
Posted Nov 18, 2025 - 07:19 CST
Investigating
As of Nov 18, 2025 - 11:48 UTC Cloudflare is experiencing a global outage. Issue is currently being investigated by Cloudflare Team. More information can be found here: https://www.cloudflarestatus.com/