Cloudflare performance problems
Incident Report for JetRails
Resolved
This issue has been resolved
Posted Nov 21, 2017 - 16:40 CST
Update
Cloudflare team has implemented a fix for this issue. We are currently monitoring the results.
Posted Nov 21, 2017 - 13:13 CST
Investigating
Cloudflare is observing network performance issues in San Jose, California. We are actively investigating this incident.
Posted Nov 21, 2017 - 13:00 CST